use strict;
my $str = 'field1,field2,Name 1,field4,field5,field6,101, field8
field1,field2,Name 2,field4,field5,field6,499, field8
field1,field2,Name 3,field4,field5,field6,500, field8
field1,field2,Name 4,field4,field5,field6,4214.00, field8';
my $regex = qr/^(?:[^,]*,){2}\K[^,\n]+(?=(?:,[^,\n]*){3},4[0-9][0-9],)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}