using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^ {2}(\d*) *<\? *(\d\.\d{2}) *- *\(multi\) *";
string substitution = @"\1,\2,multi,";
string input = @" 0 <? 0.00 - (multi) Salt";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}