$re = '/^ {2}(\d*) *<\? *(\d\.\d{2}) *- *\(multi\) */';
$str = ' 0 <? 0.00 - (multi) Salt';
$subst = "\1,\2,multi,";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;