const regex = /^ {2}(\d*) *<\? *(\d\.\d{2}) *- *\(multi\) */;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^ {2}(\\d*) *<\\? *(\\d\\.\\d{2}) *- *\\(multi\\) *', '')
const str = ` 0 <? 0.00 - (multi) Salt`;
const subst = `\1,\2,multi,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);