import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ {2}(\\d*) *<\\? *(\\d\\.\\d{2}) *- *\\(multi\\) *";
final String string = " 0 <? 0.00 - (multi) Salt";
final String subst = "\\1,\\2,multi,";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}