// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^ {2}(\d*) *<\? *(\d\.\d{2}) *- *\(multi\) *").unwrap();
let string = " 0 <? 0.00 - (multi) Salt";
let substitution = "\\1,\\2,multi,";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}