re = /^ {2}(\d*) *<\? *(\d\.\d{2}) *- *\(multi\) */
str = ' 0 <? 0.00 - (multi) Salt'
subst = '\\1,\\2,multi,'
result = str.sub(re, subst)
# Print the result of the substitution
puts result