#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[\s\'](\w+)\-(\w+)"
Local $sString = "SELECT some-name, some-name FROM [some-name] WHERE [some-name] = 'some-name'" & @CRLF & _
""
Local $sSubst = "\1 - \2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)