// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[\s\'](\w+)\-(\w+)").unwrap();
let string = "SELECT some-name, some-name FROM [some-name] WHERE [some-name] = 'some-name'
";
let substitution = "\\1 - \\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}