re = /[\s\'](\w+)\-(\w+)/
str = 'SELECT some-name, some-name FROM [some-name] WHERE [some-name] = \'some-name\'
'
subst = '\\1 - \\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result