use strict;
my $str = 'SELECT some-name, some-name FROM [some-name] WHERE [some-name] = \'some-name\'
';
my $regex = qr/[\s\'](\w+)\-(\w+)/p;
my $subst = '\\1 - \\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";