package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\s\'](\w+)\-(\w+)`)
var str = `SELECT some-name, some-name FROM [some-name] WHERE [some-name] = 'some-name'
`
var substitution = "\1 - \2"
fmt.Println(re.ReplaceAllString(str, substitution))
}