import Foundation
let pattern = #"[\s\'](\w+)\-(\w+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
SELECT some-name, some-name FROM [some-name] WHERE [some-name] = 'some-name'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1 - \2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)