# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(http:\/\/)\S*(\.test\.mywebsite\.com:8080)/$1some_new_value$2/gm;t' <<< "File 1 :
myVarString=abc
myVarUrl=http://aaaaa.test.mywebsite.com:8080
File 2 :
myVarString=abc
myVarUrl=http://bbbbbbbbbbb.test.mywebsite.com:8080
File n :
myVarString=abc
myVarUrl=http://nnnnnnnnnnn.test.mywebsite.com:8080
"