import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http://)\\S*(\\.test\\.mywebsite\\.com:8080)";
final String string = "File 1 :\n"
+ "myVarString=abc\n"
+ "myVarUrl=http://aaaaa.test.mywebsite.com:8080\n\n"
+ "File 2 :\n"
+ "myVarString=abc\n"
+ "myVarUrl=http://bbbbbbbbbbb.test.mywebsite.com:8080\n\n"
+ "File n :\n"
+ "myVarString=abc\n"
+ "myVarUrl=http://nnnnnnnnnnn.test.mywebsite.com:8080\n";
final String subst = "$1some_new_value$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}