re = /(http:\/\/)\S*(\.test\.mywebsite\.com:8080)/m
str = 'File 1 :
myVarString=abc
myVarUrl=http://aaaaa.test.mywebsite.com:8080
File 2 :
myVarString=abc
myVarUrl=http://bbbbbbbbbbb.test.mywebsite.com:8080
File n :
myVarString=abc
myVarUrl=http://nnnnnnnnnnn.test.mywebsite.com:8080
'
subst = '$1some_new_value$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result