using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http://)\S*(\.test\.mywebsite\.com:8080)";
string substitution = @"$1some_new_value$2";
string input = @"File 1 :
myVarString=abc
myVarUrl=http://aaaaa.test.mywebsite.com:8080
File 2 :
myVarString=abc
myVarUrl=http://bbbbbbbbbbb.test.mywebsite.com:8080
File n :
myVarString=abc
myVarUrl=http://nnnnnnnnnnn.test.mywebsite.com:8080
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}