const regex = new RegExp('(http://)\\S*(\\.test\\.mywebsite\\.com:8080)', 'gm')
const str = `File 1 :
myVarString=abc
myVarUrl=http://aaaaa.test.mywebsite.com:8080
File 2 :
myVarString=abc
myVarUrl=http://bbbbbbbbbbb.test.mywebsite.com:8080
File n :
myVarString=abc
myVarUrl=http://nnnnnnnnnnn.test.mywebsite.com:8080
`;
const subst = `$1some_new_value$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);