use strict;
my $str = 'File 1 :
myVarString=abc
myVarUrl=http://aaaaa.test.mywebsite.com:8080
File 2 :
myVarString=abc
myVarUrl=http://bbbbbbbbbbb.test.mywebsite.com:8080
File n :
myVarString=abc
myVarUrl=http://nnnnnnnnnnn.test.mywebsite.com:8080
';
my $regex = qr@(http://)\S*(\.test\.mywebsite\.com:8080)@mp;
my $subst = '$1some_new_value$2';
my $result = $str =~ s@$regex@$subst@rg;
print "The result of the substitution is' $result\n";