# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^|\n)([^|]*\|){5}(.*)/\1\3/g;t' <<< "note,:264058|Feb 14 2009 new document|54012|0411|2016|new document|new medicine|book store|784512|Ontario|Canada|80023569
note,:264058|Feb 14 2009 new document|54012|0411|2016|new document|new medicine|book store|784512|Ontario|Canada|80023569"