use strict;
my $str = 'note,:264058|Feb 14 2009 new document|54012|0411|2016|new document|new medicine|book store|784512|Ontario|Canada|80023569
note,:264058|Feb 14 2009 new document|54012|0411|2016|new document|new medicine|book store|784512|Ontario|Canada|80023569';
my $regex = qr/(^|\n)([^|]*\|){5}(.*)/p;
my $subst = '\\1\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";