using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|\n)([^|]*\|){5}(.*)";
string substitution = @"\1\3";
string input = @"note,:264058|Feb 14 2009 new document|54012|0411|2016|new document|new medicine|book store|784512|Ontario|Canada|80023569
note,:264058|Feb 14 2009 new document|54012|0411|2016|new document|new medicine|book store|784512|Ontario|Canada|80023569";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}