// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(^|\n)([^|]*\|){5}(.*)").unwrap();
let string = "note,:264058|Feb 14 2009 new document|54012|0411|2016|new document|new medicine|book store|784512|Ontario|Canada|80023569
note,:264058|Feb 14 2009 new document|54012|0411|2016|new document|new medicine|book store|784512|Ontario|Canada|80023569";
let substitution = "\\1\\3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}