$re = '/(^|\n)([^|]*\|){5}(.*)/';
$str = 'note,:264058|Feb 14 2009 new document|54012|0411|2016|new document|new medicine|book store|784512|Ontario|Canada|80023569
note,:264058|Feb 14 2009 new document|54012|0411|2016|new document|new medicine|book store|784512|Ontario|Canada|80023569';
$subst = "\1\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;