import re
regex = re.compile(r"(^|\n)([^|]*\|){5}(.*)")
test_str = ("note,:264058|Feb 14 2009 new document|54012|0411|2016|new document|new medicine|book store|784512|Ontario|Canada|80023569\n"
"note,:264058|Feb 14 2009 new document|54012|0411|2016|new document|new medicine|book store|784512|Ontario|Canada|80023569")
subst = "\\1\\3"
result = regex.sub(subst, test_str)
if result:
print(result)