import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^N;|[bdi]:[0-9.E-]+;|s:[0-9]+:\".*\";|a:[0-9]+:\\{.*\\}|O:[0-9]+:\"[A-Za-z0-9_\\\\]+\":[0-9]+:\\{.*\\}$";
final String string = "N;\n"
+ "b:0;\n"
+ "b:1;\n"
+ "i:0;\n"
+ "i:1;\n"
+ "i:-1;\n"
+ "d:0;\n"
+ "d:1;\n"
+ "d:-1;\n"
+ "d:-1.2;\n"
+ "s:0:\"\";\n"
+ "s:3:\"foo\";\n"
+ "a:0:{}\n"
+ "a:6:{i:0;N;i:1;b:0;i:2;i:0;i:3;d:0;i:4;s:2:\"''\";s:3:\"foo\";s:5:\"\"bar\"\";}\n"
+ "O:8:\"stdClass\":0:{}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}