# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^N;|[bdi]:[0-9.E-]+;|s:[0-9]+:\".*\";|a:[0-9]+:{.*}|O:[0-9]+:\"[A-Za-z0-9_\\]+\":[0-9]+:{.*}$"
test_str = ("N;\n"
"b:0;\n"
"b:1;\n"
"i:0;\n"
"i:1;\n"
"i:-1;\n"
"d:0;\n"
"d:1;\n"
"d:-1;\n"
"d:-1.2;\n"
"s:0:\"\";\n"
"s:3:\"foo\";\n"
"a:0:{}\n"
"a:6:{i:0;N;i:1;b:0;i:2;i:0;i:3;d:0;i:4;s:2:\"''\";s:3:\"foo\";s:5:\"\"bar\"\";}\n"
"O:8:\"stdClass\":0:{}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.