use strict;
my $str = 'N;
b:0;
b:1;
i:0;
i:1;
i:-1;
d:0;
d:1;
d:-1;
d:-1.2;
s:0:"";
s:3:"foo";
a:0:{}
a:6:{i:0;N;i:1;b:0;i:2;i:0;i:3;d:0;i:4;s:2:"\'\'";s:3:"foo";s:5:""bar"";}
O:8:"stdClass":0:{}';
my $regex = qr/^N;|[bdi]:[0-9.E-]+;|s:[0-9]+:".*";|a:[0-9]+:{.*}|O:[0-9]+:"[A-Za-z0-9_\\]+":[0-9]+:{.*}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}