// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^N;|[bdi]:[0-9.E-]+;|s:[0-9]+:".*";|a:[0-9]+:{.*}|O:[0-9]+:"[A-Za-z0-9_\\]+":[0-9]+:{.*}$"#).unwrap();
let string = "N;
b:0;
b:1;
i:0;
i:1;
i:-1;
d:0;
d:1;
d:-1;
d:-1.2;
s:0:\"\";
s:3:\"foo\";
a:0:{}
a:6:{i:0;N;i:1;b:0;i:2;i:0;i:3;d:0;i:4;s:2:\"''\";s:3:\"foo\";s:5:\"\"bar\"\";}
O:8:\"stdClass\":0:{}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}