using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(""model.*\{.*(\n.*)+?\n.+\},)";
string input = @"{
""model"": {
""template"": ""model.txt"",
""directory"": ""app/models"",
""filename"": ""{{Entity}}.php""
""moar"": ""moar.php""
},
{
""other"": {
""template"": ""model.txt"",
""directory"": ""app/models"",
""filename"": ""{{Entity}}.php""
},";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}