import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\"model.*\\{.*(\\n.*)+?\\n.+\\},)";
final String string = "{\n"
+ " \"model\": {\n"
+ " \"template\": \"model.txt\",\n"
+ " \"directory\": \"app/models\",\n"
+ " \"filename\": \"{{Entity}}.php\"\n"
+ " \"moar\": \"moar.php\"\n"
+ " },\n"
+ "{\n"
+ " \"other\": {\n"
+ " \"template\": \"model.txt\",\n"
+ " \"directory\": \"app/models\",\n"
+ " \"filename\": \"{{Entity}}.php\"\n"
+ " },";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}