re = /("model.*\{.*(\n.*)+?\n.+\},)/
str = '{
"model": {
"template": "model.txt",
"directory": "app/models",
"filename": "{{Entity}}.php"
"moar": "moar.php"
},
{
"other": {
"template": "model.txt",
"directory": "app/models",
"filename": "{{Entity}}.php"
},'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end