// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"("model.*\{.*(\n.*)+?\n.+\},)"#).unwrap();
let string = "{
\"model\": {
\"template\": \"model.txt\",
\"directory\": \"app/models\",
\"filename\": \"{{Entity}}.php\"
\"moar\": \"moar.php\"
},
{
\"other\": {
\"template\": \"model.txt\",
\"directory\": \"app/models\",
\"filename\": \"{{Entity}}.php\"
},";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}