# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\d+$\R*//mg;t' <<< "code code code
7362
code code code
code code code
code code code
63
code code code
..."