$re = '/^\d+$\R*/m';
$str = 'code code code
7362
code code code
code code code
code code code
63
code code code
...';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;