use strict;
my $str = 'code code code
7362
code code code
code code code
code code code
63
code code code
...';
my $regex = qr/^\d+$\R*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";