re = /^\d+$\R*/m
str = 'code code code
7362
code code code
code code code
code code code
63
code code code
...'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result