const regex = /^\d+$\R*/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+$\\R*', 'mg')
const str = `code code code
7362
code code code
code code code
code code code
63
code code code
...`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);