# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?m)(?<=^ *) {4}/ /gi;t' <<< "{
\"Foo\": \"bar\",
\"Kestrel\": {
\"Endpoints\": {
\"Http\": {
\"Url\": \"http://*:2201\"
},
\"HttpsInlineCertStore\": {
\"Url\": \"https://*:2203\",
\"SslProtocols\": [
\"Tls12\",
\"Tls13\"
],
\"Certificate\": {
\"Subject\": \"SubjectName\",
\"Store\": \"My\",
\"Location\": \"CurrentUser\",
\"AllowInvalid\": \"True\"
}
}
}
}
}"