import Foundation
let pattern = #"(?m)(?<=^ *) {4}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
{
"Foo": "bar",
"Kestrel": {
"Endpoints": {
"Http": {
"Url": "http://*:2201"
},
"HttpsInlineCertStore": {
"Url": "https://*:2203",
"SslProtocols": [
"Tls12",
"Tls13"
],
"Certificate": {
"Subject": "SubjectName",
"Store": "My",
"Location": "CurrentUser",
"AllowInvalid": "True"
}
}
}
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)