re = /(?m)(?<=^ *) {4}/i
str = '{
"Foo": "bar",
"Kestrel": {
"Endpoints": {
"Http": {
"Url": "http://*:2201"
},
"HttpsInlineCertStore": {
"Url": "https://*:2203",
"SslProtocols": [
"Tls12",
"Tls13"
],
"Certificate": {
"Subject": "SubjectName",
"Store": "My",
"Location": "CurrentUser",
"AllowInvalid": "True"
}
}
}
}
}'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result