import re
regex = re.compile(r"(?m)(?<=^ *) {4}", flags=re.IGNORECASE)
test_str = ("{\n"
" \"Foo\": \"bar\",\n"
" \"Kestrel\": {\n"
" \"Endpoints\": {\n"
" \"Http\": {\n"
" \"Url\": \"http://*:2201\"\n"
" },\n"
" \"HttpsInlineCertStore\": {\n"
" \"Url\": \"https://*:2203\",\n"
" \"SslProtocols\": [\n"
" \"Tls12\",\n"
" \"Tls13\"\n"
" ],\n"
" \"Certificate\": {\n"
" \"Subject\": \"SubjectName\",\n"
" \"Store\": \"My\",\n"
" \"Location\": \"CurrentUser\",\n"
" \"AllowInvalid\": \"True\"\n"
" }\n"
" }\n"
" }\n"
" }\n"
"}")
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)