import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)(?<=^ *) {4}";
final String string = "{\n"
+ " \"Foo\": \"bar\",\n"
+ " \"Kestrel\": {\n"
+ " \"Endpoints\": {\n"
+ " \"Http\": {\n"
+ " \"Url\": \"http://*:2201\"\n"
+ " },\n"
+ " \"HttpsInlineCertStore\": {\n"
+ " \"Url\": \"https://*:2203\",\n"
+ " \"SslProtocols\": [\n"
+ " \"Tls12\",\n"
+ " \"Tls13\"\n"
+ " ],\n"
+ " \"Certificate\": {\n"
+ " \"Subject\": \"SubjectName\",\n"
+ " \"Store\": \"My\",\n"
+ " \"Location\": \"CurrentUser\",\n"
+ " \"AllowInvalid\": \"True\"\n"
+ " }\n"
+ " }\n"
+ " }\n"
+ " }\n"
+ "}";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}