const regex = new RegExp('(?m)(?<=^ *) {4}', 'gi')
const str = `{
"Foo": "bar",
"Kestrel": {
"Endpoints": {
"Http": {
"Url": "http://*:2201"
},
"HttpsInlineCertStore": {
"Url": "https://*:2203",
"SslProtocols": [
"Tls12",
"Tls13"
],
"Certificate": {
"Subject": "SubjectName",
"Store": "My",
"Location": "CurrentUser",
"AllowInvalid": "True"
}
}
}
}
}`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);