using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)(?<=^ *) {4}";
string substitution = @" ";
string input = @"{
""Foo"": ""bar"",
""Kestrel"": {
""Endpoints"": {
""Http"": {
""Url"": ""http://*:2201""
},
""HttpsInlineCertStore"": {
""Url"": ""https://*:2203"",
""SslProtocols"": [
""Tls12"",
""Tls13""
],
""Certificate"": {
""Subject"": ""SubjectName"",
""Store"": ""My"",
""Location"": ""CurrentUser"",
""AllowInvalid"": ""True""
}
}
}
}
}";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}