#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[\s\S]*?<div\sid=\"variationsTwister[\s\S]*?>[\s\S]*?<div[\s\S]*?<span[\s\S]*?<span[\s\S]*?>([\s\S]*?)<\/span>"
Local $sString = " <div id="variationsTwister" class="a-section a-spacing-mini">" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" <div class="a-section a-spacing-micro">" & @CRLF & _
" <span class="a-size-base">Size:</span>" & @CRLF & _
" <span class="a-size-base a-text-bold">6 M US</span>" & @CRLF & _
" </div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")