import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\s\\S]*?<div\\sid=\\\"variationsTwister[\\s\\S]*?>[\\s\\S]*?<div[\\s\\S]*?<span[\\s\\S]*?<span[\\s\\S]*?>([\\s\\S]*?)<\\/span>";
final String string = " <div id=\"variationsTwister\" class=\"a-section a-spacing-mini\">\n"
+ " \n\n"
+ " \n\n\n\n\n\n\n\n\n"
+ " \n"
+ " \n\n"
+ " <div class=\"a-section a-spacing-micro\">\n"
+ " <span class=\"a-size-base\">Size:</span>\n"
+ " <span class=\"a-size-base a-text-bold\">6 M US</span>\n"
+ " </div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}