const regex = /[\s\S]*?<div\sid=\"variationsTwister[\s\S]*?>[\s\S]*?<div[\s\S]*?<span[\s\S]*?<span[\s\S]*?>([\s\S]*?)<\/span>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\s\\S]*?<div\\sid=\\"variationsTwister[\\s\\S]*?>[\\s\\S]*?<div[\\s\\S]*?<span[\\s\\S]*?<span[\\s\\S]*?>([\\s\\S]*?)<\\\/span>', 'gm')
const str = ` <div id="variationsTwister" class="a-section a-spacing-mini">
<div class="a-section a-spacing-micro">
<span class="a-size-base">Size:</span>
<span class="a-size-base a-text-bold">6 M US</span>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}