package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\s\S]*?<div\sid=\"variationsTwister[\s\S]*?>[\s\S]*?<div[\s\S]*?<span[\s\S]*?<span[\s\S]*?>([\s\S]*?)<\/span>`)
var str = ` <div id="variationsTwister" class="a-section a-spacing-mini">
<div class="a-section a-spacing-micro">
<span class="a-size-base">Size:</span>
<span class="a-size-base a-text-bold">6 M US</span>
</div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}