import re
regex = re.compile(r"[\s\S]*?<div\sid=\"variationsTwister[\s\S]*?>[\s\S]*?<div[\s\S]*?<span[\s\S]*?<span[\s\S]*?>([\s\S]*?)<\/span>", flags=re.MULTILINE)
test_str = (" <div id=\"variationsTwister\" class=\"a-section a-spacing-mini\">\n"
" \n\n"
" \n\n\n\n\n\n\n\n\n"
" \n"
" \n\n"
" <div class=\"a-section a-spacing-micro\">\n"
" <span class=\"a-size-base\">Size:</span>\n"
" <span class=\"a-size-base a-text-bold\">6 M US</span>\n"
" </div>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")